throttle body replaced, but SES on again - p0507 - - Infiniti G35 & G37 Forum Discussion | setemail.ru

Go Back > >
Reload this Page >

throttle body replaced, but SES on again - p0507


G35 Sedan V35 2003-06 Discussion about the 1st Generation V35 G35 Sedan

throttle body replaced, but SES on again - p0507


Old 09-09-2010, 02:23 PM
Registered User
Thread Starter
Join Date: May 2010
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
throttle body replaced, but SES on again - p0507

this is really pissing me off. so i've been through the throttle body relearn about 10 times already and each time, the same thing seems to happen - it idles normal around 650 - 750 rpm after the relearn procedure, but then within a day, it jumps back up to 850-900 rpm so the SES is legit. i just have no f'n idea. is the idle control a separate piece? i thought it was part of the throttle body assembly.

a little history - the light came on about 3 months ago - so i had the throttle body cleaned. i cleared the SES and it came back 250 miles later. so then i replaced the throttle body completely - still seeing the same problem even after it's been cleared.

i went to autozone to get my SES diagnosed and it comes back with p0507

"idle speed control system RPM higher than expected"

probably cause (given to me by autozone):

-large vacuum leak
-faulty throttle control actuator
-throttle body damage

i've replaced the the throttle body so it can't be the last 2 - so i'm left with 'large vacuum leak'. does someone know how to diagnose this issue? i have a 2003 sedan.
Old 09-09-2010, 07:02 PM
Registered User
iTrader: (14)
Join Date: Jun 2008
location: SoCal, OC
Posts: 521
Thanked 39 Times in 35 Posts
What was the error code read when the SES first came on and what did you notice 3 months ago? How did you know it's the throttle body? There are cases that replacing tb didn't fix the problem. Do an extensive search using keywords "P0507" "throttle body cleaning" "high idle" "idle reset" if you haven't done so. This is a common issue on 2002 - 2005 Nissan and Infiniti cars, check Infiniti TSB ITB05-042.

If there's a large vacuum leak you should get a code, and the idle would be rough. Make sure you don't have any vacuum leak and time the relearn procedure precisely. If all options are exhausted then you might have to send it in to get it fixed.
Old 09-09-2010, 09:20 PM
CG4DR's Avatar
Registered User
iTrader: (12)
Join Date: Apr 2010
location: FL
Posts: 3,139
Thanked 36 Times in 31 Posts
go through the key reset and it should fix it..

Old 09-10-2010, 03:08 PM
Registered User
iTrader: (1)
Join Date: Mar 2008
location: Astoria, NY
Posts: 696
Thanks: 0
Thanked 1 Time in 1 Post
^+1
Old 09-10-2010, 04:50 PM
Registered User
Thread Starter
Join Date: May 2010
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by StormTroopa View Post
go through the key reset and it should fix it..

when i first got an SES the code was p1121 - electronic throttle control actuator. mechanic said throttle body - made sense...it was really gunky.

I'm not sure what you mean by "key reset" but i've reset the ECU and still a no go following the manual procedure and the SES goes off and comes back. I read somewhere to unhook the negative terminal on the battery overnight and that is the same thing. i might try that tonight.

apparently this is a 2002 -2005 nissan thing and it's happened to a lot of people - p0507 after replacing/cleaning throttle body. same issues for them too. a consult II might be the way to go in the end. moral of the story is - if you so much and look at your throttle body the wrong way, you might be f'd.
Old 09-10-2010, 08:01 PM
Registered User
iTrader: (14)
Join Date: Jun 2008
location: SoCal, OC
Posts: 521
Thanked 39 Times in 35 Posts
Read this: . Some people got it working, so just give it a try.

From my search, it's crucial to disconnect the battery before you clean/replace throttle body. If you move the butterfly without disconnecting the battery you could have a hard time get it back to normal.
Old 09-10-2010, 09:17 PM
CG4DR's Avatar
Registered User
iTrader: (12)
Join Date: Apr 2010
location: FL
Posts: 3,139
Thanked 36 Times in 31 Posts
did he move the throttle plate when he cleaned it? if so you need to replace the throttle body. you are not suppose to move the plate bc of the splines/teeth on the actuators on the inside
Old 09-11-2010, 04:07 AM
Bozookah's Avatar
Registered User
iTrader: (3)
Join Date: Aug 2010
location: San Jose, CA
Posts: 236
Thanks: 0
Thanked 3 Times in 2 Posts
Same problem has happened to me too but luckily I took my car in for an oil change last week at my local mechanic shop. I told him the problem and I said no matter how many time I reset it would still came back (I thought my TB is done). He said he will take a look and pulled out his OBDII reader device and went for a test drive, after he came back and the car was idling like it was before I cleaned the TB, no more SES light up until now and it seemed to be back to normal again. Honestly, I dont know what the hell he did with his little obdII "device" but it worked. So technically you can fix this problem without replacing a new throttle body.

Try calling and ask around local mechanic shops, they have their own little tricks that nobody knows lol
Old 09-13-2010, 10:06 AM
Registered User
Thread Starter
Join Date: May 2010
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by StormTroopa View Post
did he move the throttle plate when he cleaned it? if so you need to replace the throttle body. you are not suppose to move the plate bc of the splines/teeth on the actuators on the inside
that was my first thought - which is why i was so quick to replace the throttle body when this happened the very first time. but when i had it replaced i made sure he didn't touch the valve at all.

ray - yeah...when it was replaced, i made sure he disconnected the battery before touching the TB. i'm definitely going to try out that info from the link you posted. definitely some differences from what he said worked, and what is stated on the relearn procedures.
Old 09-13-2010, 06:10 PM
CG4DR's Avatar
Registered User
iTrader: (12)
Join Date: Apr 2010
location: FL
Posts: 3,139
Thanked 36 Times in 31 Posts
i noticed when i had mine replaced, infiniti doesn't give you a brand new one, they send refurbished ones. refurbished suck and can always go bad
Old 09-13-2010, 10:34 PM
Registered User
Join Date: Jun 2010
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
Cool throttle body relearn

A couple steps to add to the relearning procedure. I attempted the reset 10+ times and it would work until I turned the car off. Here is some help:

These are the three items I believe (after 10+ hours of research on many nissan/infiniti forums) are neglected/ or not-emphasized enough:

1. Reset the ecm before the idle relearn procedure (may or may not be necessary, but it is suggested by many people)

2. In the final step of 'idle relearn':

The manual says release the pedal within three seconds of the light on. You must release the pedal AND start the engine within the three seconds. So you have three seconds to let go, and then start the car. THis is not explicitly stated.

3. After performing the reset and idle is OK, you must restart the car within 10 seconds of turning it off. So, if the idle goes back to normal after the reset, make sure to turn the car off and start it back up within a few seconds.

This is a summary of the info I was able to collect and fixed my idle. This seems to be a big problem, especially since the FSM is not COMPLETELY explicit or complete. I can cite some references if needed.
Old 09-13-2010, 11:53 PM
Registered User
Join Date: Sep 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
altima-03-high-idle-after-routine-throttle-body-cleanup

Originally Posted by ray1370 View Post
Read this: . Some people got it working, so just give it a try.

From my search, it's crucial to disconnect the battery before you clean/replace throttle body. If you move the butterfly without disconnecting the battery you could have a hard time get it back to normal.
Hey Ray

I had posted the original issue on the Altima forum about two years ago and just got this linkback to you guys. I would like to say that I know how frustrating this issue is, so I'll try to shed some light on the subject as these cars are blood related.

DO NOT change the throttle body if you have this problem. You will only be wasting your money. You should be able to have the system re-learn without replacing anything.

I am sure the process of re-learn for your G35's must be a bit different from my Altima, the computer for the G35's may react the same and get the RPM's low after the process is completed but will just come back after you start your engine, same as the 3.5 Altima. But the process I tried and tested only works well with the 2.5 or four cylinder models.

For the time being and as Ray stated, you must disconnect the battery before performing any mechanical work around the throttle or you will loose the RPM setting once again. The throttle has a linear resistance disc inside that reacts to the blade position sending the proper signal to the computer. There's really no electronics inside, so don't believe what they say about easily damaging the unit.

Hope this helps (a bit) and sorry for jumping lanes....
Old 09-14-2010, 12:23 AM
Registered User
Join Date: Jun 2010
Posts: 7
Thanks: 0
Thanked 1 Time in 1 Post
^

^+1

If you get to the point of having a good idle (650 +-50), just make sure to turn the car back on after you shut it off WITHIN 10 seconds. Otherwise, you'll be happy to have a good idle, only to turn the car off and be disappointed when you turn it back on. (mine kept going to back to 950).

I did this twice just to make sure and it was good after that. Learned this on the Altima forum.

If you compare several of the FSM's, for these Nissan's, the procedures are almost all identical. (including the G35). PM if you would like further details. I struggled with this for several days.
Old 09-14-2010, 02:47 AM
Registered User
iTrader: (14)
Join Date: Jun 2008
location: SoCal, OC
Posts: 521
Thanked 39 Times in 35 Posts
Originally Posted by AltimaPR View Post
Hey Ray

I had posted the original issue on the Altima forum about two years ago and just got this linkback to you guys. I would like to say that I know how frustrating this issue is, so I'll try to shed some light on the subject as these cars are blood related.

DO NOT change the throttle body if you have this problem. You will only be wasting your money. You should be able to have the system re-learn without replacing anything.

I am sure the process of re-learn for your G35's must be a bit different from my Altima, the computer for the G35's may react the same and get the RPM's low after the process is completed but will just come back after you start your engine, same as the 3.5 Altima. But the process I tried and tested only works well with the 2.5 or four cylinder models.

For the time being and as Ray stated, you must disconnect the battery before performing any mechanical work around the throttle or you will loose the RPM setting once again. The throttle has a linear resistance disc inside that reacts to the blade position sending the proper signal to the computer. There's really no electronics inside, so don't believe what they say about easily damaging the unit.

Hope this helps (a bit) and sorry for jumping lanes....
AltimaPR, I first found your updated procedure from FX35 drivers, which got their idle fixed, so I hope this will help the OP. The re-learn procedure is the same according to the FSM. This didn't work out in my case, though, I believe others might benefit from following your instruction. Great to have you chime in, hope you don't mind the linkback.
Old 09-14-2010, 10:05 AM
Registered User
Join Date: Sep 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by ray1370 View Post
AltimaPR, I first found your updated procedure from FX35 drivers, which got their idle fixed, so I hope this will help the OP. The re-learn procedure is the same according to the FSM. This didn't work out in my case, though, I believe others might benefit from following your instruction. Great to have you chime in, hope you don't mind the linkback.
Not at all, I know the feeling and wanted to help.

Thread Tools
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes, average.

Quick Reply: throttle body replaced, but SES on again - p0507


Archive

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in:

Related pages


california tinted windows lawalpine iva-w505 manualmake your own octane boostere39 m5 engine swapzerex asian coolant4.3 stroker2015 infiniti g35 coupeg35 xxrengine sludge removal seafoamstillen supercharger nissan titanbilstein hd reviewwintermaster plus tires2008 clk550tuned 350zcaliper torque specskna-g510license plate plugs for holesautometer nexus gaugesstance cs5g35 sedan body kit nismor1conceptsdifferential gears explainedaxxess stereopure one pl14610flowmaster 80 series mufflergeneral exclaimkelly infinitysolar eclipse tint woodland hillsuniversal door lock actuator2005 infiniti g35 coupe reviewcopper crush gasketrb25det conversion350z engine rebuild kitbob long intimidator paintball gunhow to fiberglass a speaker boxwire tucksllumar tint reviewhomemade wheel bearing pullervellano wheelsmetra 70 7551rt tuning lansdale paespetus sf2006 g35 reviewgreen caliper coversandroid phonebookbuyers remorse law canadaamsoil vs mobil 1 extended performancedrive shaft cost replacepioneer avic z130g35 coupe body kitsp0340 infinitiwork varianza t1skenwood dnx7140ipod touch 4th generation not chargingaxxess wiring diagramhow to fix a faulty fuel gaugereplace fan belt costpioneer x1500dvdfast track toll violationwhat causes random misfire codewhat happens when wheel bearing goes outgrom usbcanister vent solenoid locatedjl audio w7 13.5 for salewhat is negative offset on wheelscostco garage canopycheap tpms2003 gti 0 60vmr wheels torontog35 single turboinfiniti g 45 sedanplasti dip victoria bcr34 tail lightsescort 8500how to remove sticky residue from window tintviper 7756vwhite smoke coming out of car exhaustkicker l5 12 rmsvs-xx rims